글싣는 순서
                                                                                                        1. Voice Gateway의 개요
                                                                                                        2. Analog Phone Gateway
                                                                                                        3. ISR G2
                                                                                                        4. Access Server

VoIP 디렉토리를 살펴보다가 처음 UC를 접하는 분들이 Nexpert 블로그에 들어오시면 읽기 어렵겠다는 생각을 했습니다. 어플리케이션이나 기술 위주로만 설명이 되고, 기본적인 내용이 많이 빠져있었습니다. 그래서, 이번에는 In-line Power Switch에 이어 Voice Gateway에 대해 설명하도록 하겠습니다. 시간이 나면, IP PBX 및 IP Phone에 대해서도 언급하여 나중에 “IP Telephony의 이해”라는 것으로 재 구성할까 생각 중입니다. 글을 먼저 쓰고, 나중에 연재로 묶겠다는 단순한 생각입니다.


개요
IP Telephony 를 구성하기 위한 기본 요소는 아래 그림과 같습니다. 이 그림은 “In-line Power Switch”라는 글에서 설명된 그림입니다. Voice Gateway는 PBX의 Trunk 연동 부분을 담당하고 있으며, 기존의 PSTN (전화망) 과 연동하기 위해 사용합니다.



Voice Gateway의 정의

Voice Gateway란, 이기종 망을 서로 연동하는 장비로써 Ethernet Interface와 PSTN Interface를 모두 가지고 있으며, 음성 신호를 데이터 신호로, 데이터 신호를 음성 신호로 변환하기 위한 DSP (Digital Signal Processor)를 장착한 장비입니다. 아래 그림은 일반적인 게이트웨이의 역할을 나타낸 것입니다. 기업내에서 IP Telephony 시스템과 기존의 PBX를 연동하는 그림입니다. 

현재는 Voice Gateway의 역할이 중요하지만, 점점 PSTN 연동도 SIP Trunk로 이루어지므로 먼 훗날 모든 전화기가 IP만을 사용한다면 PSTN과 함께 사라질 장비입니다.

Voice Gateway의 종류
그 용도에 따라 다양하게 구분할 수 있습니다. MGCP 프로토콜 상에서 다음과 같이 구분한 것이 가장 잘 정리된 것이라 생각되어 소개합니다. 

  • Residential Gateway
    일반적으로 댁내나 소규모 사무실에 설치되는 게이트웨이로써, 아날로그 전화기를 그대로 수용할 수 있도록 FXS 포트를 가지고 있습니다.

  • Access Gateway
    일반적으로 중대규모 기업에서 사용되는 게이트웨이로써, 기존의 아날로그 PBX와 E1 Trunk로 연동됩니다.

  • Signaling Gateway & Trunking Gateway
    기존의 No.7 신호망과 연동하여 신호를 받아주는 게이트웨이를 Signaling Gateway, 음성 (bearer)만을 받아주는 게이트웨이를 Trunking Gateway라고 하며, 사업자나 ISP에서 주로 사용합니다.

일반적으로 기업에서 Voice Gateway라고 한다면, Access Gateway를 의미한다고 생각할 수 있습니다. 대부분의 게이트웨이는 인터페이스 모듈 (인터페이스 모듈)을 탈부착이 가능하므로 자신이 원하는 Interface에 맞게 설계하는 것이 가능합니다. 시스코의 장비를 가지고 다시 한번 구분해서 보도록 하겠습니다. 

  • 아날로그 폰 게이트웨이 (Analog Phone Gateway)
    쉽게 residential gateway로 사용되는 것으로, 과거에는 ATA 186 또는 ATA 188로 나온 제품이였지만, 현재는 VG 202와 VG 204로 대체되었습니다. 또한, 24개 또는 48개 이상의 아날로그 전화기를 연동할 수 있는 VG 224 또는 VG 248과 같은 대용량 아날로그 게이트웨이가 있습니다.

  • ISR G2 (Integrated Service Router)
    가장 범용적인 기업용 게이트웨이로써, 모든 PSTN 인터페이스를 가지고 있으며, 기업의 환경에 맞게 모듈을 선택하여 장착할 수 있습니다. ISR은 라우팅 및 보안 기능에 음성 모듈을 추가하여 게이트웨이로 활용하는 장비입니다. 따라서, 기업의 경우에는 WAN 라우터 및 Voice 게이트웨이의 기능을 동시에 사용하기도 합니다.

  • Access Server
    음성 전용 장비로써 ISP나 대기업에서 사용하는 게이트웨이이며, 최대 16 E1까지 지원합니다. 시스코에서는 AS 5400XM AS 5350XM 등이 나와 있습니다.  AS 5850과 같은 대용량 게이트웨이도 있지만, 국내에서 활용도는 미미합니다. 이정도 용량은 저가의 국산 장비가 상당한 성능을 발휘하기 때문일 것입니다. 

  • Signaling Gateway
    No.7 신호망을 종단하는 장비로써, 시스코에서는 PGW 2200이라는 장비가 있습니다. 국내에서는 거의 사용되지 않는 장비입니다. 기본적으로 Sigtran (Signaling Transport)라는 프로토콜을 일반적으로 사용하여 No.7 신호를 Softswitch에 넘겨주는 역할을 수행합니다. 이 장비도 국산 장비가 가격 대비 성능비가 우수한 장비로 알려져 있습니다.

 

게이트웨이의 주요 인터페이스
아래 그림은 게이트웨이에서 주로 사용되는 PSTN 인터페이스 입니다. 

아날로그 방식에 대한 용어를 정리해 보면, 다음과 같습니다.

  • FXS (Foreign exchange Station)
    일반적으로 PSTN을 흉내내는 인터페이스로, FXO나 일반 아날로그 전화기, 팩스가 연동이며, 다이얼톤을 생성합니다.

  • FXO (Foreign Exchange Office)
    일반적으로 전화기의 흉내를 내는 인터페이스이며, FXS로 부터 dialtone(다이얼 톤)을 수신합니다.

  • E&M (Ear & Mouth 또는 receitve & transmit)
    과거에 사용되었으나 현재는 거의 사용되지 않는 아날로그 Trunk 방식입니다. 일반적으로 PBX와 PBX간에 주로 사용된 신호방식입니다.

E1 PRI 또는 E1 R2는 국내에서 일반적인 Trunking 방식으로 하나의 회선에 30 채널을 사용할 수 있습니다. PRI니 R2니 하는 것은 신호방식입니다. KT나 데이콤 등과 같은 ISP에 회선을 신청하시면 주는 트렁크로 E1 PRI는 현재 가장 널리 사용되며, 안정적이며, E1 R2는 과거의 주로 사용되었으며, 시그널링 시간이 좀 긴 것이 단점입니다. 몇몇 사업자의 경우 E1 PRI Card가 충분히 확보되지 않아 E1 R2를 주는 경향이 많은 데, 사업자를 바꿀 수 있다면, PRI를 확보할 수 있습니다. 

시스코 아날로그 보이스 게이트웨이
아래 그림을 보시면 가장 일반적인 사용환경을 이해할 수 있습니다. 가정에 DSL 모뎀이 있다고 가정한다면, ATA 188이라는 장비를 통해 PC와 전화기, 팩스를 동시에 연결할 수 있도록 한 장비입니다. 기업에서 사용한다면, 2개 이상의 Fax를 연결할 수 있도록 합니다. 또한, 시스코 800 Series나 1900 Series 의 라우터의 경우 ADSL 모뎀과 Voice Gateway 기능이 함께 되어 있어 두 장비를 하나로 합치는 것도 가능합니다.

실제 단말을 통해 Analog Phone Gateway의 종류에 대해 살펴보도록 하겠습니다. 아날로그 폰 게이트웨이는 이더넷 인터페이스와 FXS 인터페이스를 모두 가지고 있는 장비입니다. 아날로그의 수량에 따라 제품을 선택하도록 되어 있습니다.  
 

  • VG 202
    10/100 이더넷 인터페이스 의 개수 : 2개
    FXS의 개수 : 2개


  • VG 204
    10/100 이더넷 인터페이스의 개수 : 2개
    FXS의 개수 : 4개


  • VG 224
    10/100 이더넷 인터페이스의 개수 : 2개
    FXS의 개수 : 24개 (RJ-21  인터페이스에 Telco 케이블을 연결하여 24개 아날로그 장비 연결)

  • VG 248
    10/100 이더넷 인터페이스의 개수 : 2개
    FXS의 개수 : 48개 (RJ-21  인터페이스에 Telco 케이블을 연결)
    이 장비는 2010년도 중반에 단종될 예정인 장비로 VG 224로 대체된다고 합니다.
     

 

VG 224 이더넷 인터페이스 이중화
얼마전에 CCIE Voice Forum 에서 논의되었던 이슈로, CUCM (Call Manager)에 SCCP로 등록할 경우  Analog Phone Gateway의 Mac address를 가지고 등록을 해야합니다. 이때, 이더넷 인터페이스 이중화를 어떻게 구현해야 할지 고민이 되었던 “띠굴띠굴”님이 질문하셨고, 이에 대해 두분의 성의 있는 답변이 있어 함께 올립니다.

  • 이데넷 브리징을 이용한 해결 (김규동님이 제안)
    두개의 이더넷 인터페이스를 브리징하여 마치 하나의 라우팅 인터페이스 처럼 이용할 수 있습니다.

    stcapp ccm-group 1
    stcapp
    !
    bridge irb
    !
    !
    interface FastEthernet0/0
    no ip address
    duplex auto
    speed auto
    bridge-group 1
    !
    interface FastEthernet0/1
    no ip address
    duplex auto
    speed auto
    bridge-group 1
    !
    interface BVI1
    ip address 1.1.1.11 255.255.255.0
    !

    bridge 1 protocol ieee
    bridge 1 route ip
    !
    ccm-manager redundant-host 10.129.61.12
    ccm-manager sccp local FastEthernet0/0
    !
    !
    sccp local BVI1
    sccp ccm 1.1.1.100 identifier 2 priority 1 version 5.0.1
    sccp ccm 1.1.1.101 identifier 1 priority 2 version 5.0.1
    sccp
    !
    sccp ccm group 1
    bind interface BVI1
    associate ccm 2 priority 1
    associate ccm 1 priority 2
    !
    dial-peer voice 100 pots
    service stcapp
    port 2/0
    !
  • 샤시 MAC을 이용한 loopback address 등록 (김성원님 제안)
    VG 224 에 Loopback 주소를 설정하고, 라우팅 가능하도록 합니다. “show Diag” 를 통해 Chassi Mac address를 확인하여 CUCM에 등록합니다. Loopback의 경우 Chassi Mac을  Mac 주소로 사용합니다. 이것은 이중화를 라우팅을 통해 구현하는 방법입니다.
  • interface FastEthernet0/0
    ip address 10.1.1.1 255.255.255.0
    duplex auto
    speed auto
    !
    interface FastEthernet0/1
    ip address 10.1.2.1 255.255.255.0
    duplex auto
    speed auto
    !
    interface loopback 0
    ip address 10.1.3.1 255.255.255.0

    나머지 SCCP 구성은 위의 Config를 참조하시기 바랍니다. ^^ (이넘의 귀차니즘 때문에)

 

Analog Phone Gateway를 통한 Fax 연동
일반적으로 팩스를 연동하면 100% 문제가 없는 가라는 질문을 간혹 받습니다. 참 난처한 질문입니다. “현재 많은 기업에서 잘 사용하고 있습니다”라는 답변을 항상 드리지만, 여전히 이슈가 되는 부분입니다.  실제 성공률은 확인된 바가 없지만, 약 95% ~ 98% 정도라고 생각됩니다. 간혹, 팩스 송수신이 실패할 수도 있습니다는 의미입니다. 이 보다 실패율이 높다면, 구성상의 문제일 확률이 높으므로, Fax over IP라는 글을 보시면서 다양한 프로토콜을 사용해서 테스트해서 가장 최적의 프로토콜을 찾으시면 됩니다.

만일, Fax가 업무에서 매우 중요한 위치를 차지하는 기업은 기존의  PSTN 라인을 전화국으로 부터 받아서 별도로 연동할 것을 권고드립니다. PSTN이 FAX 송수신에서 99.999%일리는 없지만, 팩스 실패율에 있어서 VoIP보다 적은 것은 사실입니다. Fax가 발전하면서 다양한 형태가 출시되어 이기종간에 문제가 간혹 발생하고 있으며, 특히 VoIP의 경우에는 좀 더 발생하는 듯합니다.

마치며
Voice Gateway 연재의 1장과 2장을 동시에 정리하였습니다. Analog Phone Gateway에 관련된 사항은 대부분 정리가 된 듯합니다.이번 연재는 최대한 빨리 마무리 짓고 CUBE를 정리할 까 생각중입니다만, 밥벌이가 더 중요하기 때문에 항상 연재가 질질끄는 면이 있습니다.-,-:? 밥벌이에 지장없는 한으로 바꾸어야 겠습니다.

----------------------------------------------
라인하트 (CCIEV #18487)
ucwana@gmail.com (라인하트의 새로운 구글 이메일)
http://twitter.com/ucwana (라인하트의 트위터 )
http://twitter.com/nexpertnet (넥스퍼트 블로그의 트위터, 최신 업데이트 정보 및 공지 사항)
http://groups.google.com/group/cciev (시스코 UC를 공부하는 사람들이 모인 구글 구룹스)
http://groups.google.com/group/ucforum (벤더에 상관없이 UC를 공부하는 사람들이 모인 구글 구룹스)
http://cafe.nexpert.net/ (체계적인 UC 정보의 전달을 위한 카페, 아직 아무것도 없다는......)

정리하고 보니 나도 디지털 네이티브 ^____________^

Posted by 라인하트

댓글을 달아 주세요

  1. 말구 2010.01.13 09:28  댓글주소  수정/삭제  댓글쓰기

    감사합니다.^^ 잘보고 갑니다.

  2. 셜록 2010.01.13 09:42  댓글주소  수정/삭제  댓글쓰기

    잘 봤습니다.^^

  3. 띠굴띠굴 2010.01.13 10:16  댓글주소  수정/삭제  댓글쓰기

    오우...요즘들어 궁금하던차에 필요한 글이군요!! ..^^.. 잘보고 갑니다..

  4. 곰뿡 2010.01.13 21:55  댓글주소  수정/삭제  댓글쓰기

    하핫 영광입니다~ =)

  5. 쏠라구구 2010.01.17 16:07  댓글주소  수정/삭제  댓글쓰기

    ㅎㅎ 저도 밥벌이로 제 블로그에 글 포스팅이 게으려지고 있습니다^^;

    좋은 잘 항상 잘 보고 갑니다~

  6. 예주아빠 2010.02.06 23:06  댓글주소  수정/삭제  댓글쓰기

    좋은 글 감사합니다...저도 언젠가 여기에 글쓸날이 오겠죠?ㅎㅎ

  7. 드루이드 2010.03.03 20:01  댓글주소  수정/삭제  댓글쓰기

    요즘 출퇴근하면서 아이폰으로 잘보고있습니다(댓글도 아이폰으로 ㅋ)

  8. anony 2012.08.15 16:10  댓글주소  수정/삭제  댓글쓰기

    FXO (Foreign exchange station) -> FXO (Foreign exchange office) 오타인 듯 합니다.

    • 라인하트 2012.08.15 18:27  댓글주소  수정/삭제

      예리합니다.
      항상 오타와 함께하네요..
      바로 수정 하겠습니다.